Excel - Wenn Funktion mit 3 Funktionen mit mittleren Wert?

... komplette Frage anzeigen

5 Antworten

Bei auf- oder absteigenden Bedingungen sollte immer vom kleinsten zum größten bzw. umgekehrt verschachtelt werden, wie von Antitroll gelöst (DH!).

Falls du mal zwei Bedingungen hast, bei denen das nicht so einfach möglich ist (z.B. wenn A1="Haus" und A2>=50 sein soll, benutzt du die UND-Verknüpfung, dann brauchst du keine Verschachtelung. Etwa so:

=WENN(UND(A1="Haus";A2>=50);"Bedingung erfüllt";"Bedingung nicht erfüllt")

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn die Zahl in A1 steht z.B.:

=WENN(A1>6500;7%;(WENN(A1>6000;5%;0)))

...Zelle entsprechend in % formatieren.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Isi292
17.10.2016, 11:54

Super, hat perfekt geklappt

0
Kommentar von dkilli
17.10.2016, 12:04

Was passiert wenn in A1 6000 steht?

0

Vermutlich ist hierbei statt einer WENN()-Funktion eher eine VERWEIS()-Funktion sinnvoll da man hier erstens übersichtlicher arbeitet und die Bedingungen erweitern kann. 

=VERWEIS(A1;{0.6000.6500};{0.5.7})

Antwort bewerten Vielen Dank für Deine Bewertung

Es gibt bestimmt bessere Lösungen, aber ich würde es so machen,

Wenn größer  x  6000 und nicht größer 6499, dann.....

Antwort bewerten Vielen Dank für Deine Bewertung

Eine andere Formel als eine verschachtelte Wenn Funktion ist diese:

=VERWEIS(A1;{0.6000.6500};{0.5.7})
Antwort bewerten Vielen Dank für Deine Bewertung