Frage von thedigits, 46

Excel - Berechnung?

Ich hätte einmal eine Frage bzgl. Excel!

Für die Arbeit erstelle ich gerade in Excel einen Dienstplan, und würde diesen gerne etwas automatisieren. Datum und Formatierung stellt sich schon alles automatisch ein. Jedoch habe ich ein Problem beim Berechnen der Stunden, denn:

ich habe 6 Mitarbeiter, die an den Tagen DO bis SO eingesetzt werden können, dies ist aber wöchentlich unterschiedlich. So will ich also jene Zeilen raussuchen, wo zB Donnerstag vorkommt, dann möchte ich aus diesen Zeilen rausfinden, welcher mitarbeiter wie oft eingeteilt wird im Monat, und diese Anzahl mit der Stundenzahl multiplizieren;

Also Mitarbeiter A arbeitet an 2 Donnerstagen, sprich die Summe ist 7Stunden im Monat. Mein Vorschlag für den Excel-code wäre gewesen = WENN (B3:B33 = "Donnerstag"; Zählenwenn(Bereich der Suche, "MA"; "0") funktioniert ja nicht so - schon klar ;) = WENN (WOCHENTAG(B3:B33;2) = 5; Zählenwenn... man bekommt ein Array(Matrix zurückgeliefert, und kein eindeutiges ergebnis

Gibt es also eine Funktion, wo jede Zeile untersucht wird auf das Kriterium, und ein eindeutiger Rückgabewert für diese Zeile existiert...

in c könnte man es so schreiben:

 for(zeile1 = B3; zeile1 = B33; zeile1 ++){
      if(Wochentag = Freitag){
           for(zeile2 = D3; zeile2 = D33; zeile2++){
                if(eintrag = "Ma1"){
                    stunden = stunden + 3,5;
                }
           }
      }
 }

so oder so ähnlich (Syntax wird so nicht funkt. aber zum besseren Verständnis^^)

Vielen Dank! :)

Expertenantwort
von DeeDee07, Community-Experte für Excel, 23

Wenn du wissen willst, wie oft "Maier" in D3:D33 und gleichzeilig das Datum in B3:B33 ein Donnerstag ist, dann lautet die Formel:

=SUMMENPRODUKT((WOCHENTAG(B3:B33;2)=4)*(D3:D33="Maier"))

Für solche Fälle sieht Excel eigentlich die Funktionen ZÄHLENWENNS und SUMMEWENNS vor, allerdings funktionieren die nicht, wenn beim Kriterium ein variabler Zellbezug gefragt ist, wie bei der Wochentag-Funktion. Deswegen verwende ich die vielseitigere SUMMENPRODUKT-Funktion in Verbindung mit Wahrheitswerten.

Antwort
von Noctisrules, 24

Kann mir das Layout , dass du vor dir hast noch nicht ganz vorstellen.

Schreibst du in der Spalte nach dem Namen "Donnerstag, Freitag, Donnerstag, Samstag" wenn er an den vier Tagen arbeitet? Oder ist für jedes Datum eine Spalte?

Antwort
von daynlol, 9

Ich frage mich ehrlich gesagt, wieso ihr euch so eine Mühe macht, euren Dienstplan mit Excel zu erstellen...

Es gibt gute Alternativen, die online basiert funktionieren.

Wir nutzen zB das Angebot von https://www.9plan.de

Keine passende Antwort gefunden?

Fragen Sie die Community