Frage von RapidMiner, 48

Einige Plugins werden nicht geladen! Kann mir einer sagen was der Fehler ist und wie ich ihn beheben kann!?

Hey, ich habe einen Spigot Server erstellt und alles klappt super, aber einige Plugins werden einfach nicht geladen! Kan mir einer sagen was der Fehler ist und wie ich diesen beheben kann!?

Hier der Log des Terminals:

[21:59:16 INFO]: Starting minecraft server version 1.8.8 [21:59:16 INFO]: Loading properties [21:59:16 INFO]: Default game type: ADVENTURE [21:59:16 INFO]: This server is running CraftBukkit version git-Spigot-5f38d38-18fbb24 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT) [21:59:17 INFO]: Debug logging is disabled [21:59:17 INFO]: Server Ping Player Sample Count: 12 [21:59:17 INFO]: Using 4 threads for Netty based IO [21:59:17 INFO]: Generating keypair [21:59:17 INFO]: Starting Minecraft server on 25.45.54.146:25565 [21:59:17 INFO]: Using default channel type [21:59:18 ERROR]: Could not load 'plugins/SurvivalGamesMultiverse.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: se/lucasarnstrom/survivalgamesmultiverse/Main : Unsupported major.minor version 51.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot_server.jar:git-Spigot-5f38d38-18fbb24] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot_server.jar:git-Spigot-5f38d38-18fbb24] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot_server.jar:git-Spigot-5f38d38-18fbb24] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot_server.jar:git-Spigot-5f38d38-18fbb24] at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot_server.jar:git-Spigot-5f38d38-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot_server.jar:git-Spigot-5f38d38-18fbb24] at java.lang.Thread.run(Thread.java:695) [?:1.6.0_65] Caused by: java.lang.UnsupportedClassVersionError: se/lucasarnstrom/survivalgamesmultiverse/Main : Unsupported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.6.0_65] at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) ~[?:1.6.0_65] at java.lang.ClassLoader.defineClass(ClassLoader.java:621) ~[?:1.6.0_65] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) ~[?:1.6.0_65] at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) ~[?:1.6.0_65] at java.net.URLClassLoader.access$000(URLClassLoader.java:58) ~[?:1.6.0_65] at java.net.URLCla

Dann geht es normal weiter und die restlichen Plugins werden geladen.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von ZombiemamLP, 48

Könntest du vll. mal eine Pluginliste reinschreiben? Spontan fällt mir ein:
Die plugins vertragen sich nicht
Die plugins haben ne falsche version

Kommentar von RapidMiner ,

Die Plugins sind:

Bedwars.jar

ClearChat.jar

ClearLag.jar

CommandBook.jar

CraftBook.jar

Jump.jar

Multiverse-Core-2.4.jar

Spleef.jar

SuperBuildBattle.jar

SurvivalGames.jar

Worldedit-bukkit-6.1.jar

worldguard-6-1.jar

Alles von der neusten Version

Kommentar von ZombiemamLP ,

Hier noch mein Lösungssatz ;) : Ich hatte mit craftbook immer probleme... Ansonsten vll. n paar minigames.. Die waren bei mir auch manchmal probleme...

Antwort
von MIK333, 44

Ich habe selber die Erfahrung gemacht das wenn das Plugin nicht auf der Aktuellen Version ist, das es nur Fehler abgibt. Besonderst Spigot ist davon Betrofen. Ausserdem sind nicht alle Plugins mit Spigot Kompitabel. Deshalb gibt es von manchen Plugins "inoficielle" Versionen extra für Spigot. Ich glaube bei mir waren das Mulltiverse und Essentials.

Kommentar von RapidMiner ,

Multiverse funktioniert ja Super, was nicht funktioniert sind:

Bedwars.jar

SuperBuildBattle.jar

SurvivalGames.jar

SurvivalGamesMultiverse.jar

Kommentar von MIK333 ,

Ja eben das könnte an spigot liegen weil nicht alle plugins mit spigot gehen. Eine mögliche lösung wäre die plugins auf der offiziellen spigot seite zu suchen, und die andere wäre andere plugins zu suchen die das selbe machen aber halt mit spigot kompitabel sind.

Antwort
von MIK333, 42

Hier ist der Link zur Spigot version von Multiverse:

https://www.spigotmc.org/resources/multiverse-core.390/

Antwort
von RapidMiner, 27

DiePlugins sind:

Bedwars.jar

ClearChat.jar

ClearLag.jar

CommandBook.jar

CraftBook.jar

Jump.jar

Multiverse-Core-2.4.jar

Spleef.jar

SuperBuildBattle.jar

SurvivalGames.jar

Worldedit-bukkit-6.1.jar

worldguard-6-1.jar

Alles von der neusten Version

Kommentar von ZombiemamLP ,

Ich hatte mit craftbook immer probleme... Ansonsten vll. n paar minigames.. Die waren bei mir auch manchmal probleme...

Kommentar von ZombiemamLP ,

wäre vll noch ganz nett für die anderen zu schreiben was die lösung ist :)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten