Frage von user35272, 41

Editor oder Browser Problem?

Hallo Leute, Ich lerne gerade PHP und schreibe kleine Übungsprogramme mit dem Editor. Diese rufe ich dann im Browser (Chrome) über localhost auf. So weit so gut Allerdings ist mir aufgefallen dass der Browser Veränderungen die ich im code vorgenommen habe nicht immer sofort erkennt (ausgibt). Ja ich habe darauf geachtet die Datei zu speichern und die Seite neu zu laden. Meine Erklärung ist dass der Editor das nicht immer unmittelbar speichert wenn man auf speichern klickt oder der Browser lädt die datei nicht immer vom computer neu sondern aus irgendnem Zwischenspeicher. Das komische ist dass wenn man die Adresse mehrmals neu eingibt und lädt wird die Veränderung irgendwann angezeigt.

Das ist aber relativ blöd da ich ja wie gesagt php lerne und deshalb auch sofort wissen sollte ob etwas das ich ausprobiere auch funktioniert manchmal ändert man ja nur ein paar Zeichen und will wissen ob es trotzdem funktioniert und da ist das etwas unvorlteihaft wenn der Browser dich ersteinmal glauben macht es funktioniert alles einwandfrei und man arbeitet weiter und plötzlich fällt ihm ein es funktioneirt doch nicht und ich weiß nicht warum.

Kann mir jemand sagen warum das so ist und was ich dagegen tun kann?

Danke schon mal im vorraus XDXDXDXDXD

Antwort
von tmbergen, 27

Zum lernen empfehle ich dir einfach codecademy.com, ist für sowas perfekt geeignet. Zu deinem Problem: Wir brauchen mehr Infos!

Antwort
von webflexer, 25

Welchen Editor nutzt du?

Wo ist PHP und der Webserver installiert?

Welches Betriebssystem nutzt du?

Hast du ein Komplettpaket benutzt um den Webserver und PHP zu installieren oder hast du alles selber einzeln installiert?

Bitte einige Hintergrundinfos geben sonst wird das nix.

Antwort
von Homero, 20

Versuch mal folgendes:

setze mal in Deinen HTML Header folgendes ein:

und gib den Systemen einen Moment Zeit zwischen den Aktionen.

Vielelicht hilft das.


<meta http-equiv=“cache-control“ content=“no-cache“>

<meta http-equiv=“pragma“ content=“no-cache“>

<meta http-equiv=“expires“ content=“0″>
Antwort
von ImCedo, 19

Vielleicht mal Shift+F5

Antwort
von user35272, 3

Danke für die Antworten

Ich hab solage nicht geantwortet weil ich in letzter Zeit mit html gearbeitet habe und PHP nich gebraucht habe

Hat sich soweit erledigt da ich herausgefunden hab dass das auf Fehler im code die sich merkwürdig äußer zurückzuführen ist

Allerdings weiß ich noch nicht ob doch eine Verzögerung vorliegt

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten