Frage von AaronWallerr, 16

Eclipse Error beim Start?

Ich habe mir Eclipse Installiert, wenn ich es öffnen möchte wird mir folgende Fehlermeldung angezeigt:

failed to create java virtual machine

Könnt ihr mir sagen warum es nicht geht, und woran es liegen könnte?

Falls das wichtig ist, hier meine Eclipse.ini

-startup
plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
--launcher.library
C:\Users\Aaron\.p2\pool\plugins\org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.400.v20160518-1444
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms512m
-Xmx512m
-Declipse.p2.max.threads=10
-Doomph.update.url=<a href="http://download.eclipse.org/oomph/updates/milestone/latest">http://download.eclipse.org/oomph/updates/milestone/latest</a>
-Doomph.redirection.index.redirection=index:/-><a href="http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/">http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/</a>
-vm
"C:\ProgramFiles\Java\jdk1.8.0_101\bin\javaw.e

ps. Habe an der Eclipse.ini schon ein paar veränderungen bei "xms" und "xmx" vorgenommen da es als Lösung im Internet angegeben war, hat aber leider nichts geholfen.

LG Aaron

Antwort
von PeterKremsner, 14

Hast du die neueste Java Virtual Machine installiert?

Laut der Ini Datei versucht Eclipse die Version 1.8 zu verwenden, eine ältere Version geht nicht.

Die Werte bei XMS und XMX sollten im Standard passen.

https://www.eclipse.org/forums/index.php/t/208545/

Kommentar von AaronWallerr ,

Ja, die neuste Version von Java ist installiert (1.8). Hast du noch weitere vorschläge bzw tipps?

Kommentar von PeterKremsner ,

Zeigt der Pfad 

C:\ProgramFiles\Java\jdk1.8.0_101\bin\javaw.e

auch auf diese? bzw existiert das Programm javaw.exe in dem Ordner überhaupt?

Was ist die Ausgabe von java -version in der Eingabeaufforderung?

Keine passende Antwort gefunden?

Fragen Sie die Community