Dropdown Liste mit Zahl verknüpfen?

... komplette Frage anzeigen

4 Antworten

In A2 steht zum Beisiel Benzin. In B2 soll das Ergebnis stehen. Dort 

=WENN(A2="Benzin";1,419;1,369)

eingeben

Nur was machst du wenn sich die Liter-preise ändern? 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von FlovesTK
09.10.2016, 19:46

Danke 

Es get nur ums Prinzip, ansonsten ändere ich es oder wende deine Formel an.

1

OK, da du ja nicht schreibst in welchen Zellen du Diesel oder Benzin aussuchst und ob deine Preise in einer anderen oder in der gleichen Tabelle stehen gehe ich mal von folgendem aus.

Tabelle 1 Zelle A1 ist dein Dropdownmenü und in Tabelle 2 ist im Bereich A1 - B3 deine Tabelle hier vom Foto.

Du willst jetzt in Tabelle 1 in Zelle B1 den Preis ausgegeben bekommen, dann schreibsz du in Zelle B1 folgende Formel:

=SVERWEIS(A1;Tabelle2!A2:B3;2;0)

Klappt es?

Falls nicht musst du mir schon genau sagen wo sich deine Felder usw. befinden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von FlovesTK
09.10.2016, 12:27

Es ist zwar nicht so, wie ich es meinte, aber durch kleine unbedeutende Veränderungen klappt es

Vielen, vielen Dank

1

Hallo,

leider habe ich nicht immer die Zeit Fragen direkt beantworten zu können, und die Fragestellung liegt einige Zeit zurück.

Dennoch, falls Du bisher keine bessere Lösung gefunden hast, würde ich es so lösen.

Deine Berechnung für Spritkosten immer auf eine Zelle(n) Preis/Benzin und Preis/Diesel beziehen.

Eine Spalte verwenden indem  z. B. "B" für Benzin und "D" für Diesel, dann des weiteren wie in der Abbildung die Formel kreieren (Wichtig die $-Zeichen zum Bezug, Benzin/Diesel, der Konstant bleiben muß), dann die WENN-Formel verwenden und nach unten kopieren.

Dies wäre, ohne Dropdown, die Basis für deine Berechnungen.

Gruß Tron

Antwort bewerten Vielen Dank für Deine Bewertung

Hat eine dir eine Antwort am Besten geholfen?

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?