Frage von drolly64 23.11.2010

doppelte Zeilen in Excel vermeiden

  • Antwort von kristallvogel 24.11.2010

    Alternative

    Ausgangssituation:


    A1: Hans Müller

    A2: Gustav Gans

    A3: Hans Müller


    Du sortierst die Tabelle nach Spalte A.


    A1: Gustav Gans

    A2: Hans Müller

    A3: Hans Müller


    Und dann kannst du in Spalte B folgende Funktion eingeben: =WENN(A1=A0;"X";""). Damit markierst du jeden Eintrag, der in der Zeile davor auch schon vorkam.


    A1: Gustav Gans B1: leer

    A2: Hans Müller B2: leer

    A3: Hans Müller B3: X


    Mit dem Autofilter kannst du nun alle Zeilen ermitteln, in denen in Spalte B "X" vorkommt und diese Zeilen dann löschen.

  • Antwort von Oubyi 23.11.2010

    Mach mal folgendes (vorher Sicherheitskopie!):
    Spalte markieren;
    Daten / Filter / Spezialfilter.. ;
    evtl. Fehlermeldung wg Spaltenbeschr. ignorieren (OK);
    Aktion: Liste an gleicher Stelle kopieren /
    Häkchen bei Keine Duplikate;
    OK;
    Rechtsklick auf die markiert Spalte: Kopieren:
    Markieren einer Zelle in einer leeren Spalte, Zeile 1 (z.B. G1);
    Rechtsklick: Einfügen;
    Daten / Filter / Alle anzeigen;
    Fertig: Jetzt hast Du in der neuen Spalte die Daten der Quell-Spalte ohne die Duplikate.
    Klappt es?

  • Antwort von Wundawuzi 23.11.2010

    Hallo drolly,

    in der Menüleiste unter Daten / Gültigkeit kannst Du eine Gültigkeitsprüfung formulieren.

    Stehen bspw. die Namen in Spalte A, dann diese Spalte markieren und in den Einstellungen die Gültigkeitskriterien:

    Zulassen: Benutzerdefiniert; Formel: =ZÄHLENWENN(A:A;A1)=1; OK

    definieren.

    Dann sollte er keine doppelten WErte zulassen.

    Ich hoffe das funktioniert so, ansonsten scheu doch nicht zu fragen.

    PS: Diese Antwort stammt nicht von mir, sondern ich hab sie über Google gefunden.

    Quelle: http://www.office-loesung.de/ftopic9593000_asc.php

  • Antwort von drolly64 23.11.2010

    kleiner nachtrag ich sehe gerade dass die namen nebeneinander stehen, sollen natürlich untereinander stehen

Du kennst die Antwort? Frage beantworten
Bitte noch eine Antwort ... Frage erneut stellen
Diese Frage und Antworten teilen:

Verwandte Fragen

Fragen Sie die Community –

anonym und kostenlos!