Frage von drolly64,

doppelte Zeilen in Excel vermeiden

Gibt es eine Möglichkeit Daten in Excel abzugleichen, sprich ich habe folgende Tabelle:

Markus Schulz Gerhard Ommeringer Dietlinde Schürze Markus Schulz Joachim Kaiser

das Ergebnis sollte sein, dass der Markus Schulz nur einmal vorkommt,

Antwort von kristallvogel,

Alternative

Ausgangssituation:


A1: Hans Müller

A2: Gustav Gans

A3: Hans Müller


Du sortierst die Tabelle nach Spalte A.


A1: Gustav Gans

A2: Hans Müller

A3: Hans Müller


Und dann kannst du in Spalte B folgende Funktion eingeben: =WENN(A1=A0;"X";""). Damit markierst du jeden Eintrag, der in der Zeile davor auch schon vorkam.


A1: Gustav Gans B1: leer

A2: Hans Müller B2: leer

A3: Hans Müller B3: X


Mit dem Autofilter kannst du nun alle Zeilen ermitteln, in denen in Spalte B "X" vorkommt und diese Zeilen dann löschen.

Antwort von Oubyi,

Mach mal folgendes (vorher Sicherheitskopie!):
Spalte markieren;
Daten / Filter / Spezialfilter.. ;
evtl. Fehlermeldung wg Spaltenbeschr. ignorieren (OK);
Aktion: Liste an gleicher Stelle kopieren /
Häkchen bei Keine Duplikate;
OK;
Rechtsklick auf die markiert Spalte: Kopieren:
Markieren einer Zelle in einer leeren Spalte, Zeile 1 (z.B. G1);
Rechtsklick: Einfügen;
Daten / Filter / Alle anzeigen;
Fertig: Jetzt hast Du in der neuen Spalte die Daten der Quell-Spalte ohne die Duplikate.
Klappt es?

Kommentar von Oubyi,

War wohl nur eine Spass-Frage (:o|

Antwort von Wundawuzi,

Hallo drolly,

in der Menüleiste unter Daten / Gültigkeit kannst Du eine Gültigkeitsprüfung formulieren.

Stehen bspw. die Namen in Spalte A, dann diese Spalte markieren und in den Einstellungen die Gültigkeitskriterien:

Zulassen: Benutzerdefiniert; Formel: =ZÄHLENWENN(A:A;A1)=1; OK

definieren.

Dann sollte er keine doppelten WErte zulassen.

Ich hoffe das funktioniert so, ansonsten scheu doch nicht zu fragen.

PS: Diese Antwort stammt nicht von mir, sondern ich hab sie über Google gefunden.

Quelle: http://www.office-loesung.de/ftopic9593000_asc.php

Antwort von drolly64,

kleiner nachtrag ich sehe gerade dass die namen nebeneinander stehen, sollen natürlich untereinander stehen

Keine passende Antwort gefunden?

Verwandte Fragen

Fragen Sie die Community

Weitere Fragen mit Antworten