Frage von MM705, 24

debian partition hängt sich beim booten nicht ein was tun?

also ich habe heute auf meinem neuen computer debian installiert. Dabei ist folgendes problem aufgetreten: Nach der installation habe ich den pc rebootet und als er gestarted hat kam ein zeichen das anzeigen soll das kein OS installiert ist desswegen habe ich den pc nochmal mit einem live stcik gebootet und habe mir die partitionen angeguck und gesehen das er eigentlich das system installiert hat. Was kann ich tun damit die die partitionen beim start des computers atomartisch eingehängt werden?

danke im vorraus MM705 (Entschuldigung für mögliche rechtschreibfehler)

Expertenantwort
von guenterhalt, Community-Experte für Linux, 2

welches Zeichen wurde denn ausgegeben, aus dem schließt, dass er kein OS findet?
Das BIOS würde da schon mehr ausgeben und auch grub meldet sich mit einem Text.

Wenn dein Computer Linux bootet, dann wurde bereits die Partition gefunden, auf der der Kernel installiert wurde. Dass dann aber die root-Partition nicht gefunden wurde, ist schon eigenartig.
So etwas hatte ich an einem PC mit einer Zusatz-SATA-IDE-PCI-Karte. Da wurden bei der Installation andere Bezeichnungen  ( hd0 , hd1 ..) in grub eingetragen als dann beim Booten. So wurde dann auf eine andere gezeigt und / nicht gefunden.

Hattest du einen weiteren USB-Stick währen der Installation im Computer, der dann auch die Bezeichnungen durcheinander gebracht hat?

Versuche doch mal zu prüfen, ob die Installation wirklich vollständig ist.

Boote vom Stick, mounte die root-Partition und benutze chroot

mount /dev/sdXY /mnt

chroot /mnt

Das hilft zwar erst einmal nicht weiter, prüft aber, ob die / richtig installiert wurde.

Expertenantwort
von LemyDanger57, Community-Experte für Linux, 13

Hast du mit Gparted nachgeschaut? Schau mal, ob bei der Root-Partition das Bootflag gesetzt ist. Wenn nicht, setze das mal, geht mit Gparted. Oder bei der PArtition, auf der Du GRUB installiert hast (falls du es so gemacht hast).

Kommentar von MM705 ,

Ich habe eine einzelne Boot Partition

Kommentar von MM705 ,

Bei der auch eine bootflag Gesetzt ist

Kommentar von LemyDanger57 ,

Bist Du nach einer Anleitung vorgegangen oder hast Du "frei Schnauze" installiert?

Hier findest du deutsche Anleitunge, da stehen auch Tipps für Fehelerfälle drin:https://www.debian.org/releases/jessie/installmanual

Du könntest natürlich auch erst mal versuchen, was passiert, wenn Du das Bootflag bei der Debian-Partition setzt.

Kommentar von MM705 ,

Ich habe es ja schon mehr Mals in den letzten Monaten/ Jahren installiert da ich es bis jetzt auf jedem meiner Computer installiert habe (Außer auf einem da läuft gentoo)

Antwort
von LeonardM, 7

Evtl bootloader nicht/auf falscher partition installiert?

Bootflag auf richtiger partition (auf der -insofern getrennt- boot und bootloader)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten