Frage von ich1021, 59

Datum finden?

Ich habe Geburtstage in einer großen Tabelle. Gibt es eine Formel die nach dem aktuellen Datum das Geburtsdatum findet ohne über die normale Suche zu gehen? Also, wenn ich heute die Tabelle öffne, sollte z. B. das Feld vielleicht in einer Farbe angezeigt werden oder alternativ eine Info: Heute hat jemand Geburtstag. Ich hoffe ich habe das verständlich ausgedrückt. Ich freue mich über jede Hilfe und bedanke mich im voraus.

Expertenantwort
von Ninombre, Community-Experte für Excel, 29

Eine bedingte Formatierung für das Färben:

Zunächst den gesamten Bereich markieren für den die Regel gelten soll (also die Spalte mit den Geburtstagen, ggf. noch etwas mehr für neue Einträge). Ich nehme einfach mal an, dass es Spalte B wäre

Neue Regel > Formel zur ...
=UND(TAG(HEUTE())=TAG(B1);MONAT(HEUTE())=MONAT(B1))

Wenn Du nicht in Zeile 1 anfängst, dann entsprechend in der Formeln auch ändern. Excel übernimmt für die Zeilen darunter automatisch das hochzählen.

Kommentar von Ninombre ,

Für die Anzahl der heutigen Geburtstag kannst Du entweder mit einer Hilfsspalte arbeiten (die ausgeblendet werden kann) und zwei einfachen Formeln oder einer komplizierten Formel.

Hilfsspalte: Hier kommt eine ähnliche Formel rein wie bei der bedingten Formatierung

=WENN(UND(TAG(HEUTE())=TAG(B1);MONAT(HEUTE())=MONAT(B1))=WAHR;1;"")

Dann kannst Du gut sichtbar noch die Werte mit 1 summieren, evtl. auch mit etwas Text drumrum

=WENN(SUMME(C1:C200)>0;"Es gibt heute: "&SUMME(C1:C200)&" Geburtstag(e)";"Kein Geburtstag heute")

Wenn Du es einfacher halten willst: Einfach irgendwo als Text "Anzahl Geburtstage heute" oder ähnliches rein und in die Zelle daneben =Summe(C1:C200)

Zur Variante mit komplizierter Formel musste ich selbst suchen:
http://www.supportnet.de/fresh/2006/3/id1302155.asp Antwort 6

=ANZAHL(WENN(((TAG(B1:B249) = TAG(HEUTE())) * (MONAT(B1:B249) = MONAT(HEUTE())));B1:B249))

Da es eine Matrixformel ist, nach dem Eingaben mit STRG + SHIFT + ENTER bestätigen, damit sich noch die { } bilden. Wenn Du das nicht machst, wird zwar ein Geburtstag angezeigt aber nicht die richtige Anzahl wenn es mehrere sind.

Kommentar von ich1021 ,

Vielen Dank für die Formeln.
Mit der 1. Formel zum Einfärben, bin ich gut klar gekommen.
Funktioniert auch.
Aber mein Problem: Wenn jetzt dieser Datensatz irgendwo in der Liste an Position 651 steht und ich aber auf Datensatz 1400 arbeite, dann müsste ich ja erst einmal die ganzen Daten durch scollen um zu sehen, dass da jemand Geburtstag hat.
Also, leider noch nicht so das Gelbe vom Ei.
Und mit den Hilfsspalten tue ich mich schwer, weil ich aus anderen Arbeitsblättern auch immer wieder Datensätze übertragen muss.
Dann müsste ich überall diese Hilfsspalten einführen.

Ich benötige also eine Möglichkeit, die mir sagt, egal wo ich gerade arbeite: Heute haben 1 oder mehrere Personen Geburtstag.

Bin gespannt, ob es dafür eine Lösung gibt.  :-)

Kommentar von Ninombre ,

Die letzte Formel funktioniert ohne Hilfsspalte. Die in Zeile 1 und dann Zeile einfrieren 

Antwort
von mirolPirol, 36

Es gibt die Formel =SVERWEIS().

Damit kannst du auf ein Feld in einer Spalte referenzieren und wenn die Bedingung erfüllt ist wird die Aktion ausgeführt.

Antwort
von Madderinjo, 25

ich würde einfach einen Filter setzen. Dann drückst du auf den und gibst den tag ein und alle mit dem tag werden angezeigt :D

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten