Frage von Marcelinho76, 53

Darstellung von Wörtern und Farbe in Abhängigkeit von einem Eintrag in anderer Spalte!?

Hallo Zusammen.

Ich möchte gerne in einer Spalte "J" die Wörter "gut", "mittel", "schlecht" darstellen in Abhängigkeit vom Eintrag in Spalte "A", die zwischen 1-10, 11-20, 21-30 liegen können. Darüber hinaus sollen die drei Wörter mit drei unterschiedlichen Farben (grün, gelb, rot) dargestellt werden (Zellfarbe, nicht Schriftfarbe).

Kann mir einer sagen, wie das geht?

Danke und Gruß Roland

Expertenantwort
von Oubyi, Community-Experte für Excel, 35

Wenn gesichert ist, dass die Werte in A in diesem Bereich liegen, dann in J1 diese Formel und runterkopieren:

=VERWEIS(A1;{1;11;21};{"gut";"mittel";"schlecht"})

Für die Formatierung:
Start/ Bedingte Formatierunt/ Regeln zum Hervorheben von Zellen/ Textinhalt:
-->gut
Füllung aussuchen. OK.
Für die anderen beiden die gesamte Prozedur jeweils nochmal.

Antwort
von excelentoDOTde, 29

Das sind zwei Schritte notwendig:

1. Schritt

In deiner Spalte "J" musst du folgende Formel hinterlegen

=WENN(A1<11;"gut";WENN(A1<21;"mittel";"schlecht"))


Das geht auch eleganter, ist für deinen Zweck aber ausreichend.

2. Schritt

Bedingte Formatierung - neue Regel - Formel zur Ermittlung der zu formatierenden Zelle verwenden:

="gut"

und unter dem Button "Formatieren..." entsprechende Farben wählen. Das machst du für alle drei Optionen (mittel, schlecht).



Kommentar von Marcelinho76 ,

Vielen Dank für die Antwort. Jetzt lege ich noch einen drauf. Ich hae überall Prozentwerte stehen. Wenn der Wert in Spalte "A" zwischen 80-89% liegt und mindestens 3% größer als in Spalte "B", dann soll statt "neutral" nämlich "positiv" dort stehen.

Kommentar von excelentoDOTde ,

Versuch es mal hiermit:

=WENN(A1>=B1+3;"Positiv";WENN(UND(A1>=80;A1<=89);"Positiv";"Neutral"))
Kommentar von Marcelinho76 ,

Ich habe mir erstmal eine "Hilfsspalte" erstellt, wo die Differenz berechnet wird, wo dann 4%, 3%, 1% steht usw. Aber wie ergänze ich jetzt meine Formel mit dieser Prüfung?

Kommentar von excelentoDOTde ,

C1 wäre deine "Hilfsspalte" in der du die Range bestimmst, ab welcher Differenz "Positiv" dargestellt wird:

=WENN(A1>=B1+C1;"Positiv";WENN(UND(A1>=80;A1<=89);"Positiv";"Neutral"))
Kommentar von excelentoDOTde ,

ich glaube ich habe deine Frage falsch interpretiert, C3 wäre  weiterhin deine "Hilfsspalte" mit folgendem Code:

=WENN(C2>=3;"Positiv";WENN(UND(A2>=80;A2<=89);"Positiv";"Neutral"))

http://www.excelento.de/downloads/sonstiges/161020-Marcelinho76-1.xlsx

Antwort
von dkilli, 11

Kommen nur Ganzahlen vor oder auch Fließkommazahlen? Zu was zählt zum Beispiel 10,9 ?

Antwort
von Drakus86, 33

Bedingte Formatierung.

Wenn du Excel etwas beherrschst, dann sollte es klappen.

Falls nicht, melde dich einfach.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten