Connection refused ...?

... komplette Frage anzeigen

3 Antworten

Bei solchen Problemen wäre es immer nützlich, ein paar mehr Informationen zu geben: Welche Linux-Distribution, welcher http-Server wird verwendetß Funktioniert wget, wenn nicht auf localhost zugegriffen werden soll? Auch die genaue (Fehler-) Meldung wäre interessant, so wie hier zum Beispiel:

http://superuser.com/questions/720851/connection-refused-vs-no-route-to-host

Vielleicht hilft Euch die zweite Antwort in diesem thread.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von wolfgang9999
02.11.2015, 18:46

Ich wollte Dir eigentlich ein Like geben ... sorry. Dafür bekommst Du ein Danke:-)
Weitere Infos:

- VirtualBox

- Ubuntu

- xinetd installiert

- Tomcat drauf

0

wahrscheinlich funktioniert der Web-Browser mit der Adresse

localhost:80

auch nicht. Das deutet darauf hin, dass der http-Server ( apache2 ? ) nicht läuft.

mit

systemctl start apache2.service

könnte der gestartet werden (natürlich als root ) .


Antwort bewerten Vielen Dank für Deine Bewertung

Wir haben die Lösung mittlerweile gefunden. Es lag daran, dass wir einen Netzwerkdienst eingerichtet haben, dessen Executables, auf die unser Dienst  zugreift, nicht für den Nutzer freigegeben waren, mit dem wir darauf zugegriffen haben. Mit "sudo chmod 777 <Filename>" kann diesem Problem Abhilfe geschaffen werden.

Wer Probleme mit wget hat, kann über wget -d den Debug-Modus anwerfen und weitere Rechtevergaben prüfen kann.

Antwort bewerten Vielen Dank für Deine Bewertung