calc soll in einer Zelle nach einem bestimmten wort suchen, (wie) geht das?

... komplette Frage anzeigen

1 Antwort

Leider schon sehr lange her, aber vllt hilfts ja noch etwas:

=VERGLEICH(".*Wort.*";A$1:A$99;0)

gibt die Zeilennummer wieder, in der das Wort in Spalte A gefunden wird.

Im Ggs zu xl ist das Wildcard-Zeichen in LO nicht nur *. sondern .*

.* steht für beliebig lange Fragmente, das Wort darf also davor und danach von anderem Text umgeben sein (muss aber nicht: .* kann auch "gar nichts" bedeuten)

Genau 1 Zeichen stellt dagegen .? dar, wenn man also weiß, dass vor dem Fragment exakt 2 beliebige Zeichen stehen und danach irgendwas undefiniertes, dann

=VERGLEICH(".?.?Wort.*";A$1:A$99;0)

Vergleich findet allerdings immer nur das erste Auftreten des gesuchten Wortes!

ggf muss man ab der ersten Zeile nach der Findung die Suche mit einer neuen Zeile beginnen: wird zB das Wort in A27 gefunden, dann

=VERGLEICH(".*Wort.*";A28:A$99;0)+27

Das +27 deshalb, weil Vergleich die Zellnummer in A28:A$99 wiedergibt, aber 27 Zeilen ja schon davor sind. Als Formel automatisiert:


=VERGLEICH(".*Wort.*";A28:A$99;0)+Zeile(A28)-1

Antwort bewerten Vielen Dank für Deine Bewertung