Frage von LolerMC, 24

Bukkit Fehler: (Is it up to date)?

Ich habe ein Plugin programmiert das bis vor kurzer Zeit noch funktionierte aber jetzt kann man nicht mehr damit machen in der Konsole kommt der Fehler:

    [15:59:18 ERROR]: Error occurred while enabling System v4.0 (Is it up to date?)
java.lang.NullPointerException
        at de.lolermc.Main.registerCommands(Main.java:136) ~[?:?]
        at de.lolermc.Main.onEnable(Main.java:52) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

Meine Main.java:

http://pastebin.com/QDer8uiF

Kann mir jemand Helfen? Es ist sehr dringen

Antwort
von PerfectMuffin, 21

Offenbar ist "getCommand("friend")" null.

Überprüf' das.

Kommentar von LolerMC ,

Oh danke! Du hast mir wirklich geholfen! Du hast das ganze Netzwerk gerettet! (Ich ich hatte den Befehl friend nicht mehr in der plugin.yml) Echt danke!!!

Kommentar von PerfectMuffin ,

Das verriet ein kurzer Blick auf die Fehlermeldung und ein ebensokurzer Blick auf den Code.

Es ist enorm wichtig, dass du als Programmierer die Fehlermeldungen verstehst.

Keine passende Antwort gefunden?

Fragen Sie die Community