Frage von Hadi1987, 88

Brauche Hilfe bei Excel :/ Komme leider nicht weiter..?

Und zwar geht´s um folgendes.

Ich hab in Spalte B (B1:B20) irgendwelche Texte stehen. Spalte C (C1:C20) dazugehörige Namen. (Mehrmals die gleichen)

Und in Zelle C25 soll die Formel rein.

D.h.

C25 =Suche in C1:C20 den bestimmten namen, zähle wie oft und gebe mir die dazugehörigen Werte in B1:B20 als Text aus.

Ist das machbar? Danke jetzt schonmal für eure Hilfe!

Lg

Antwort
von gfntom, 6

Ich habe noch nicht verstanden, was du willst.

Beispiel mit nur 3 Zeilen:
B1: "eins"
B2: "zwei"
B3: "drei"

C1: "Anton"
C2: "Berta"
C3: "Anton"

-> was soll in C25 nun ausgegeben werden?

Antwort
von Rubezahl2000, 41

Also in Celle C 25 möchtest du als Ergebnis die Anzahl bekommen, wie oft ein bestimmter Name (welcher?) in Spalte B vorkommt.
Der entsprechende Excel Befehl ist: zählenwenn

Und was willst du als Text ausgeben?

Antwort
von pert96, 56

Benutze den SVerweis

Kommentar von Hadi1987 ,

Hab ich schon versucht, aber irgendwie kriege ich das nicht hin.

Wichtig wäre vllt zu wissen, dass die Namen in C via Dropdown geändert werden können

Kommentar von Hadi1987 ,

Was ich gemacht hab ist folgendes

=SVERWEIS(F116 [Der bestimmte Name];A1:B20;2;FALSCH)

Aber irgendwie klappt das nicht.

Kommentar von augsburgchris ,

Warum? Weil der das Allheilmittel ist?

Oh ich weiss in Excel nicht wie ich erreichen soll, was ich möchte: SVERWEIS

Oh es gibt Krieg im nahen Osten: SVERWEIS

In Afrika gibt es Hungersnot: SVERWEIS

Kommentar von Jackie251 ,

Top ! augsburgchris, besser kann man es nicht sagen

Kommentar von Iamiam ,

Der SVerweis ist wie das schröpfen früher in der Medizin: Weil ich nicht mehr weiter weiß, empfehle ich das eben. Ein Armutszeugnis für alle, die nicht die konkrete Formel-Ausführung angeben.

Im übrigen liefert auch der SVerweis nur das erste Auftreten, wovon der Frager ausdrücklich beschrieben hat, dass das nicht reicht. "...Namen. (Mehrmals die gleichen)..."

Antwort
von azmd108, 48

Zählen:


=Zählenwenn(C1:C20;"Dieter")

Alle "Texte" in B ausgeben, wo der Name gefunden wurde (untereinander)
Formel mit STRG+SHIFT+Enter abschließen! Die untere Formel anschließend runterziehen. Du kannst den Namen natürlich auch aus einer Zelle lesen.

=WENNFEHLER(INDEX($B$2:$B$20;KGRÖSSTE(($C$2:$C$20="Dieter")*(ZEILE($C$2:$C$20)-1);ZÄHLENWENN($C$2:$C$20;"Dieter")+1-ZEILE(B1)));"")
Kommentar von Hadi1987 ,

Das hilft mir schon viel weiter, jedoch kommt der Name jetzt 3 mal vor (C1,C2,C3) und er gibt mir nur B4 aus, dabei wäre es nett von Excel, wenn er mir B1,B2 und B3 ausgibt

:/

Kommentar von azmd108 ,

?? du musst die Formel als Matrixformel eingeben, so wie ich es geschrieben habe mit STRG SHIFT und Enter die Formel bestätigen. Dann ziehst du die Formel einfach runter, sollte funktionieren, oder was meinst du

Kommentar von Hadi1987 ,

Hab ich genau so gemacht, wie du es gesagt hast inkl. STRG + SHIFT und ENTER. Aber er soll ja die mehreren Werte, die in B stehen mir hier in einer Zelle ausgeben :/

Kommentar von azmd108 ,

In EINER Zelle geht nicht ohne VBA-Programmierung. Mithilfe von Formeln geht es nur untereinander oder nebeneinander.

Was du machen könntest wäre die einzelnen, untereinander aufgelisteten ergebnisse so zu verknüpfen, ist aber undynamisch:


=A1&" "&A2&" "&A3

Kommentar von Hadi1987 ,

Ahh ok, gut. Aber jetzt ist noch meine Frage, warum er den Wert drunter angibt, quasi in C4 gefunden, aber B5 ausgegeben

Kommentar von azmd108 ,

Verstehe dein Problem leider nicht, ohne die Mappe zu sehen, ist es sehr abstrakt. Kannst du die vllt hochladen und hier einen Link posten?

Kommentar von Hadi1987 ,

Ok, ne habs jetzt. Hab einfach die Formel umgeändert. Da, wo du "-1" geschrieben hattest, hab ich "-2" gemacht und am Ende "+1" so passts. Vielen Dank

Kommentar von augsburgchris ,

Versuch mal das. Auch als Arrayformel eingeben mit Steuerung+Hochstelltaste+Eingabetaste abschließen

=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(C$2:C$20="Dieter";ZEILE($2:$20));ZEILE(A1)));"")

Kommentar von Iamiam ,

@ A-Chris:Genau so! nur index(B:B... anstatt ...A:A..., weil die Texte ja in B:B stehen.

Schön, dass du jetzt wieder vermehrt eingreifst, hab Deine Antworten lange vermisst!

@ Hadi: -1 0der -2 kommt drauf an. wo die Formel steht.

Kommentar von augsburgchris ,

Stimmt, mea culpa. Kommt davon wenn man die Formeln ohne Excel zusammenschreibt.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten