Frage von Japetus, 103

Brauche Hilfe bei der Erstellung einer Excel-Formel, kann mir jemand behilflich sein?

Hallo liebe GF-Gemeinde,

da ich relativ faul bin, dachte ich mir, ich erstelle eine Excel-Formel, damit ich nicht alles manuell ausrechnen muss, leider muss ich nun zugeben, dass meine Grundkenntnisse wohl nicht ausreichend sind.

Ich möchte mit der Formel alle Punkte in einer bestimmten Spalte ausrechnen, die sich z.B. in der KW 37 befinden.

Damit es verständlich ist, habe ich ein Bild hinzugefügt. KW 37 ( 12.9-18.9.16 ). Wäre super hilfreich, wenn man jetzt aus der Spalte " A " alle X zusammenrechnen könnte ( X = 1 ).

Ich hoffe, dass mir jemand helfen kann.

Expertenantwort
von DeeDee07, Community-Experte für Excel, 54

Bei Excel-Screenshots bitte immer auch die Zeilen- und Spaltenköpfe mitaufnehmen. Sonst kann man keine Zellpositionen feststellen und nur allgemeine Formeln bauen.

Möglichkeit 1: Du zählst alle x, die zwischen zwei Datümern liegen (Anfang und Ende der Woche). Das machst du mit ZÄHLENWENNS. Etwa so:

=ZÄHLENWENNS(A:A;">=12.09.2016";A:A;"<=18.09.2016";B:B;"x")

Möglichkeit 2: Du erstellst eine weitere Spalte, mit der Funktion KALENDERWOCHE und verwendest diese als Kriterium in ZÄHLENWENNS (statt der beiden Datümer).

Kommentar von Japetus ,

Ehrlich gesagt bin ich gestern auch noch selber auf die zweite Methode drauf gekommen.

Allerdings scheint da was falsch zu sein, vielleicht sagt es dir mehr was?

=ZÄHLENWENNS(D5:D15;"<>0";(B5:B15=37))

Von B5 bis B15 stehen die KW ( 37 und 38 )

Kommentar von DeeDee07 ,

die Syntax ist falsch.

=ZÄHLENWENNS(D5:D15;"<>0";B5:B15;37)

Kriterienbereich und Kriterium werden mit ; getrennt. Die andere Variante, wo ein Bereich mit einem Wert verglichen wird (B5:B15=37) findet man bei Matrixformeln wie SUMMENPRODUKT, welche man als alternative Lösung für deine Frage verwenden könnte, etwa

=SUMMENPRODUKT((D5:D15<>0)*(B5:B15=37))

Kommentar von Japetus ,

Danke Dir!

Alles funktioniert einwandfrei. 

Noch eine letzte Frage, ist es möglich statt einen Bereich zu markieren, gleich die ganze Spalte zu verwenden?

Kommentar von DeeDee07 ,

Verwendest du Open-/LibreOffice? Falls ja, welche Version?

Also bei mir funktioniert die Formel in beiden Programmen.

Ja, du kannst eine ganze Spalte verwenden. Statt B5:B15 schreibst du B:B. Das funktioniert aber nicht in OpenOffice (in neueren Versionen von LibreOffice schon).

Kommentar von Japetus ,

Jetzt zurzeit habe ich OpenOffice Calc, auf der Arbeit Excel 2010.

Habe es gerade ausprobiert, geht bei mir nicht, ist aber auch nicht so dramatisch.

Trotzdem Danke.

Kommentar von Japetus ,

Sehe leider nicht wie man inzwischen einen Stern für die hilfreichste Antwort vergibt, vielleicht muss man erst eine bestimmte Zeit warten.

Kommentar von DeeDee07 ,

Wie gesagt, in OO funktioniert es nicht. Inzwischen favorisiere ich (und andere hier auch) LibreOffice.

Du kannst eine Antwort erst 24h nach Fragestellung als hilfreichste auszeichnen.

Kommentar von Japetus ,

Eine Frage hätte ich da noch! :)

Vielleicht kannst Du mir auch dabei helfen.

Wie stelle ich eine Verbindung zwischen zwei Excel bzw. ODS Dateien her? Ich möchte die obere Formel in eine zweite Datei einfügen, um die Ergebnisse zu bekommen.

Kommentar von DeeDee07 ,

Öffne beide Dateien im gleichen Programm. Wenn du in einer Formel einen Bezug auf eine andere Datei setzen willst, dann wechsle während der Eingabe zur anderen Datei und markier die Zelle oder den Bereich. Wechsle wieder zurück, dann sollte der Bezug in der Formel stehen.

Kommentar von Japetus ,

Das ist echt komisch, wenn ich die Formel mit ZÄHLENWENNS verwende, dann kommt nur : 0                                                    =ZÄHLENWENNS('file:///C:/Users/Bernie/Desktop/123.ods'#$Sheet1.D5:D15;"<>0";'file:///C:/Users/Bernie/Desktop/123.ods'#$Sheet1.B5:B15;37)

Mit der SUMMENPRODUKT Formel klappt das zwar, aber die Änderungen werde nicht übernommen, auch wenn ich die Datei speichere.

Antwort
von cub3bola, 84

=ZÄHLENWENN(A1:A20;"x")

Kommentar von Japetus ,

Würde es dann nicht alle X zählen, unabhängig von der KW?

Kommentar von cub3bola ,

A1:A20 war jetzt nur so ein Beispiel. Könnte auch A1:D1 sein, sprich eben waagrecht statt senkrecht verlaufen. Alternative kannste auch durch den Formelassistenten quasi beliebe Felder anklicken und die eben zählen. Das Ergebis landet halt in dem einen Feld wo die Formel ist.

Kommentar von Japetus ,

Hmm... anscheinend hast du mich falsch verstanden, mit KW meinte ich die Kalenderwoche.

Wenn man eine Tabelle über 2000 Zeilen und 50 Spalten hat, ist es sehr mühsam ständig jede einzelne Spalte für jede KW zu markieren.

Kommentar von cub3bola ,

aso du willst das die formel zuerst schaut wieviele zeilen in die woche gehören und dann die ganzen x der dazugehörigen spalten zählt, ja?

Kommentar von Japetus ,

Genau

Kommentar von cub3bola ,

Hm ich geh jetzt schlafen und schau hier vermutlich nicht mehr rein ...

Müsste aber irgendwie so gehen
=ZÄHLENWENN(A1:A20;"x"   und   =KALENDERWOCHE(A2;2)
wobei ich grad nicht weiß wie das mit "und" also doppelter Bedingung geht, aber so müsstest du das hinkriegen.

Kommentar von cub3bola ,

Sorry bin müde ... müsste jetzt selbst grad ausprobieren und ist mir zu umme ... aber das ist halt das grundgerüst der formel musste nur noch das Feintuning machen - bestimmt hilft dir wer anders. Gute Nacht.

Kommentar von Japetus ,

Ich glaube, da müsste man dann stattdessen =ZÄHLENWENNS verwenden.

Werde dann weiterhin ausprobieren, trzm danke! :)

Kommentar von cub3bola ,

hm ja oder kaskadenformel also "wenn" "dann" - kriegs jetzt nicht so hin aber grob gesagt die formel funktioniert dann so: wenn kalenderwoche = die richtige - dann zählen ---- WENN ((KALENDERWOCHE=xxxxxx;ZÄHLENWENN(der bereich hier;"x");"0")

oder irgendwie so, sry muss jetzt echt pennen, viel Glück -- und ich schau Morgen nochmal hier rein und helf dir falls kein Anderer in die Bresche springt, nicht das dir der Chef am Montag noch den Hals umdreht^^

Schlaf gut, bye

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten