Frage von exceldummie, 65

Wie funktioniert das mit der Berechnung von sumproduct in Excel?

Ich möchte Altersgruppen auffüllen. Ich habe die Gruppen 0-3 Monate, 4-6 Monate, 7-9 Monate, 10-12 Monate, 13-18 Monate,19-24 Monate, 25-36 Monate, bis 4 Jahre, bis 5 Jahre und eine Liste mit Kindernamen und deren Alter die in diese Gruppen einsortiert werden sollen. Kindno1: 40 Monate alt, Kindno2: 27,4 Monate alt etc.

Ich dachte das geht mit sumproduct also =SUMPRODUCT((F4:F43=0)*(F4:F43<=3)) --> ich möchte also in dieser Spalte die Anzahl der Kinder ausgeben lassen, die zwischen 0-3 Monaten alt ist. Ich habe die Monate dazu extra in Dezimalzahlen umgerechnet. Leider funktioniert das nicht.

Die weitere Frage wäre dann noch, wie kann ich die weiteren Altersgruppen (4-6 Monate, 7-9 Monate etc. automatisieren ohne immer in jeder Spalte die Einträge händisch einzugeben?

Und kann ich auch evtl. das Geschlecht mit einbeziehen?

Vielleicht ist sumproduct hier auch gar nicht die richtige Funktion?! ich habe es auch mit countif probiert aber nichts hat funktioniert.

Vielen Dank für die Hilfe!

Antwort
von Jackie251, 29

man müsste man sehen wie deine Tabelle überhaupt aufgebaut ist, was genau stehen denn für Einträge in Spalte F
wenn dort Text drin steht kann Excel natürlich nicht auswerten zu welcher Gruppe ein Kind gehört.

Die Formel ergibt jedoch schon aus Mathematischer Sicht so gar keinen Sinn.

(F4=0)*(F4<=3)
F4 = 0 liefert immer den Wert 0 es sei denn F4 ist 0, das wird 1 ausgespuckt.
F4 <= 3 macht genau die gleiche Prüfung, nur mit einem größerem Bereich.
Das Produkt aus beiden wir immer 0 ergeben, außen in Spalte F steht gerade selbst schon eine 0 (was in gewisser Weise unlogisch ist, da man selten ein Alter von 0 haben kann)

Kommentar von Iamiam ,

Seh ich auch so.

Guck Dir mal die Formel HÄUFIGKERT() an, aber lies unbedingt die Hilfe dazu durch!

Und: auch die funktioniert nur, wenn Du Zahlen hast. Am besten so:

Alter = HEUTE()-Geburtsdatum, das aktualisiert sich täglich.

Und eben alles in Tagen denken und rechnen.

Geschlecht: dafür eigene Spalte mit m, w anlegen und bei Bedarf getrennt auswerten, hinterher erst Summe beider Geschlechter bilden

Kommentar von Iamiam ,

immer wieder gute Erklärungen liefert P. Haserodt, hier zu Häufigkeit:

http://www.online-excel.de/excel/singsel.php?f=146

Kommentar von Iamiam ,

Die Formel heißt englisch übrigens =FREQUENCY(Daten,Klassen)

Daten ist das Alter in Tagen, Klassen die Abgrenzung der Gruppen

Und nicht vergessen: eine Zelle mehr ausfüllen (wie in Hilfe!)!

Antwort
von iMPerFekTioN, 40

Hallo,

vielleicht ist das die richtige Formel;

=SUMMENPRODUKT([MATRIX];MTRANS(MATRIX))

Als Matrixformel abschließen, STRG+SHIFT+ENTER

Grüße,

iMPerFekTioN

Kommentar von exceldummie ,

kannst du das anhand des Beispiels bisschen näher erläutern? also wenn ich =SUMPRODUCT((F4:F43=0)*(F4:F43<=3)) hätte, wie übertrage ich das dann sinnvoll auf deine Formel? Bei mir kommt da immer eine Fehlermeldung

Kommentar von iMPerFekTioN ,

Hallo,

ich habe sogar was noch besseres :p

Die Formel mit STRG+UMSCH+ENTER abschließen!

=SVERWEIS(A1;{0."Gruppe1";4."Gruppe2";7."Gruppe3";10."Gruppe4";13."Gruppe5";19."Gruppe6";25."Gruppe7";37."Gruppe8";49."Gruppe9"};2;1)

Es wird die Matrix angefragt und der dazugehörige Wert ausgegeben.
Schreibe die Formel in A1 und gebe ein Alter in B1 ein.

Dann siehst du was passiert :p

Antwort
von Maimaier, 29

(F4:F43=0)

Vermutlich >= anstatt =

Kommentar von exceldummie ,

das bringt leider auch nichts =(

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten