Frage von insideboy, 90

benötige eine Formel wenn im Feld + oder - steht und im zweiten Feld (..#) als Ergebnis 1 oder -1 addieren mit mehren Felder?

zum Beispiel Feld 1 [+] und Feld 2 [.##] = 2

oder Feld 2 [-] und Feld 2 [..#] = -1

es sind in 3 spalten ein plus und minus vorhanden aber nur die mit den # dürfen im Ergebnis ein plus oder minus im Endergebnis anzeigen.

Hier noch ein Foto vom ganzem

http://www.fotos-hochladen.net/uploads/neuebitmap2kx45cq3jvi.jpg

so das Beispiel:

Wenn .## =2 oder ..# =1 im Feld K,Y,AN
aber nur dann wenn ein + oder - im Feld ist F,h,I, in Verbindung mit K, der nächste mit T,V,W in Verbindung Y, der nächste AH,AJ,AM in Verbindung mit AN
wenn kein +/- vorhanden ist kein Ergebnis wenn ein - dann das Ergebnis -1

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 53

Also für jedes + rechnest du +1, für jedes - rechnest du -1? Das mit dem .## habe ich nicht verstanden.

+/- Lösung: 

=ZÄHLENWENN(A1:D1;"+")-ZÄHLENWENN(A1:D1;"-")
Kommentar von insideboy ,

das Zählen passt schon aber nur wenn im anderen Feld (.##) ist oder (..#) und er soll dann wenn es 2 # sind Ergebnis 2 machen

Kommentar von Suboptimierer ,

Gib mal Beispiele

+ + - + .## = ?
- - - - .## = ?
- - - - #.# = ?
+ + - + #.# = ?
+ + + + ..# = ?
+ + + + ### = ?
Kommentar von insideboy ,

Beispiel 

Feld F39 [+]   Feld K39 ..# = 1

Feld F40 [+]   Feld K40 .## = 2

Feld F41 [-]   Feld K41 ..#  = -1

Feld F42 [-]   Feld K42 .## = -2

Kommentar von Suboptimierer ,

Achso, du zählst die # und stellst das Vorzeichen aus Spalte F vor. Richtig?

Dann hat Oubyi gute Vorarbeit geleistet:

=WENN(F39="-";-1;1)*(LÄNGE(K39)-LÄNGE(WECHSELN(K39;"#";"")))
Kommentar von Suboptimierer ,

Was auch geht:

=VORZEICHEN((F39="+")-0,5)*(LÄNGE(K39)-LÄNGE(WECHSELN(K39;"#";"")))

(nette Spielerei)

Kommentar von insideboy ,

es sind auch Felder wo kein + oder minus drin steckt da macht er mit deiner Formel dennoch + 2 im Endergebnis http://www.fotos-hochladen.net/uploads/neuebitmap2kx45cq3jvi.jpg

Kommentar von insideboy ,

und die längen müssen wir kürzen damit die anderen neben dran getrennt gezählt werden mit minus und plus vielen dank erstmal hat mir ziemlich weiter geholfen

Expertenantwort
von Oubyi, Community-Experte für Excel, 55

Ich habe Dich so verstanden:

=WENN(A1="+";LÄNGE(A2)-LÄNGE(WECHSELN(A2;"#";""));WENN(A1="-";(LÄNGE(A2)-LÄNGE(WECHSELN(A2;"#";"")))*-1;""))

A1 (+ oder -)  und A2 (.##) als Text formatiert, Formelzelle benutzerdefiniert formatiert als:

+0;-0;0

War es so gemeint?
Das "mit mehreren Feldern" müsstest Du allerdings noch erläutern.

P.S.: Kann sein, dass es auch eine einfachere Formel gibt, habe im Moment leider keine Zeit mehr zu "friemeln".

Kommentar von insideboy ,

hauptsache es passt ich zeig nochmal was ich alles brauch

F15 ist ein plus aber es soll nur +1 rechnen wenn im anderen feld (.##) Ergebenis 2 oder (..#) vorhanden ist Ergebnis 1

Kommentar von Oubyi ,

hauptsache es passt

Das musst Du schon selber ausprobieren.


Deine Beschreibungen empfinde ich als etwas wirr.
Ganze Sätze wären hilfreich.

Kommentar von insideboy ,

Entschuldigung für die Ausdrucksweise 

Hier nochmal ein Beispiel:

Beispiel 

Feld F39 [+]   Feld K39 ..# = 1

Feld F40 [+]   Feld K40 .## = 2

Feld F41 [-]   Feld K41 ..#  = -1

Feld F42 [-]   Feld K42 .## = -2

Kommentar von Oubyi ,

Und was passt Dir jetzt an meiner Formel nicht?
Ich finde, sie funktioniert genau SO!
Die Zelladressen kannst Du doch sicherlich selber anpassen, oder?

Kommentar von insideboy ,

hab es angewendet funktioniert aber nicht.

http://www.fotos-hochladen.net/uploads/neuebitmap2kx45cq3jvi.jpg

Kommentar von Oubyi ,

Zeige mal die Formeln die Du verwendet hast.
SO kann ich mit dem Bild nichts anfangen.

Kommentar von insideboy ,

=SUMMENPRODUKT(MMULT(--(K6:K89={"|.##|"."..#|"});{1;1});(ISTTEXT(F6:F89)+ISTTEXT(H6:H89)+ISTTEXT(J6:J89)))

aber als Ergebnis bekomme ich 4 raus und nicht 8 wenn ich das ganze zusammen zähle


Kommentar von Oubyi ,

Das hat mit meiner Formel nichts mehr zu tun.
Da halte ich mich dann ab sofort raus, zumal Du meine Formel offensichtlich immer noch nicht getestet hast.

Kommentar von insideboy ,

deine Formel funktioniert auch nicht sonst hätte ich sie schon angewendet !

Kommentar von Oubyi ,

Beispiel aus Deiner Tabelle:

In V28 (als Text formatiert) steht ein: -
In Y28 steht: |..##|
In AA28 steht meine - angepasste - Formel:
=WENN(V28="+";LÄNGE(Y28)-LÄNGE(WECHSELN(Y28;"#";""));WENN(V28="-";(LÄNGE(Y28)-LÄNGE(WECHSELN(Y28;"#";"")))*-1;""))Anzeige in AA28:
-2

WAS ist daran FALSCH?

Antwort
von trickytricky91, 47

=WENN(F39<0+(G39="..#");-1;WENN(F39<0+(G39=".##");-2;WENN(F39>=0+(G39="..#");1;WENN(F39>=0+(G39=".##");2;""))))

In Spalte F sind in diesem Fall die + und - Werte und in Spalte G die ..# Werte.

Wenn ich einen Screenshot + gute Erklärung hätte könnte ich es vielleicht noch besser machen.

oder als Formel

=WENN(Posting=Screenshot+guteErklärung;guteAntwort;wenigerguteAntwort)

Kommentar von insideboy ,

ich hoffe mit dem Bild wird es klappen es sind ja immer 3 reihen die zusammen zusätzlich noch addiert werden

Kommentar von insideboy ,

bei deiner Formel zählt er nur 1 als Ergebnis es müssten aber 2 sein bei 2 # 

Kommentar von trickytricky91 ,

Ich habe noch nicht ganz verstanden, in welcher zelle was für ein Ergebnis stehen soll und was benötigt wird, um auf das Ergebnis zu kommen. Der Screenshot hilft schon mal weiter, aber mit fehlt noch eine gute Erklärung.

Was man aber auch immer gut machen kann, ist nicht die gesamte Formel in ein Feld zu packen.

Bedeutet:

Du schreibst am ende der Tabelle eine WENN Funktion, die dir schon mal ein Ergebnis gibt, in der Spalte daneben dann die nächte WENN Funktion mit dem nächsten Ergebnis und immer so weiter, bis du alle Zwischenergebnisse hast.

Dann noch eine letzte Formel. die nach deinen Voraussetzungen alles zusammen rechnet und fertig.

Kommentar von insideboy ,

hab die Formel angewendet irgendwie passt die aber nicht 

=SUMMENPRODUKT((($F$7:$F$89="+")+($H$7:$H$89="+")+($J$7:$J$89="+")*($F$7:$F$89="-")+($H$7:$I$89="-")+($J$7:$J$89="-")>0)*((K7:K89="|.##|")*2+(K7:K89="|..#|")*1))

Antwort
von trickytricky91, 54

=SUMME(A1+A2+A3)

Oder suchst du etwas anderes?

Kommentar von insideboy ,

das wäre ja zu einfach   in 3 spalten ist ein Inhalt von + oder - 

diese 3 spalten plus eine 4 spalte ist der Inhalt von (###) , (#.#) , (.##) , (.#.) nur 2 bestimmte # und plus die 3 spalten soll der das ganze ausrechen

Kommentar von trickytricky91 ,

kannst du vielleicht einen Screenshot hochladen? kann mir das nur schwer vorstellen, kann dir aber bestimmt helfen

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten