Frage von FrageXstellerex, 23

Bei Excel Wenn-Dann Funktion?

Hallo. Man hat bei Excel beispielsweise die Funktion: =WENN(A1=0;"Ja";"Nein"). Man möchte nun, dass wenn "Ja" ist, "Ja" grün sein soll, wenn "Nein" ist, soll es schwarz sein (die Schriftfarbe). Wie funktioniert das oder geht das überhaupt?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 13

Wenn Du schwarz als Standardfarbe hinterlegt hast, brauchst Du nur eine bedingte Formatierung. Nur wenn die Bedingung zutrifft, wird grün verwenden, ansonsten greift ja der Standard mit schwarzer Farbe.

Bereich markieren, für den diese bedingte Formatierung gelten soll. Dann s. Bild. Im weiteren Auswahlmenü auf benutzerdefiniert und dort die Schriftfarbe ändern.

Du kannst bei bedingten Formatierungen auch mit Formeln arbeiten. Das wäre für Deinen Fall nicht notwendig - kann aber auch andere Bedingungen geben, die mit Standardeinstellungen eben nicht abgebildet werden können.
Dazu bei bed. Formatierung > neue Regel > Formel zur Ermittlung... auswählen.
Abweichend zu anderen Formeln mit Bedingung: Es wird hier nur auf wahr und falsch abgefragt. Für Deinen Fall wäre es also
=A1=0
Wenn A1 = 0 ist, dann ist die Bedingung erfüllt und die Zelle wird gem. der hinterlegten Regel formatiert. Man hinterlegt also nicht =wenn(a1=0....

Antwort
von kragenweiter, 18

Hier benötigst du die Bedingte Formatierung. Die ist sozusagen das Gleiche wie die Wenn-Funktion, bezieht sich aber nicht auf den Inhalt, sondern auf das Format. In den Dialogen wirst du die selben Infos einstellen müssen, wie du das jetzt auch schon für deine Wenn-Funktion durchdacht hast.

Zelle = "Ja" -> grüne Farbe
zelle = "Nein" -> schwarze Farbe

Beide Versionen müssen angelegt werden! Vorher würde ich alle Formatierungen in der Zelle entfernen, damit du direkt siehst, ob es funktioniert.

Antwort
von Copyyy, 16

Das geht nicht in der Formel, du musst die Zelle formatieren.
Start  -> Bedingte Formatierung und da das auswählen, was du brauchst. Zellen, auf die es angewandt werden soll, natürlich vorher formatieren

Antwort
von Sariashd, 23

Dieser Artikel hier hilft dir weiter: http://praxistipps.chip.de/zellenfarbe-in-excel-per-wenn-funktion-aendern_25605

Aber anstatt kleiner-als (wie im Artikel) wählst du entspricht. Dann einmal mit Ja und einmal mit Nein.

Liebe Grüsse
Lars

Antwort
von Flash8acks, 12

Hier hilft eine "Bedingte Formatierung", die bei dem Wort die Zellenfarbe wechselt. Alternativ ist der Einsatz eines Macro möglich.

Antwort
von Tron1701, 2

Hallo,

angenommen deine Formel steht in B2, dann in B2 folgende "Bedingte Formatierung".

"Bedingte Formatierung" - "Neue Regel" - "Formel zur Ermittlung ... " anklicken und bei "Regelbeschreibung bearbeiten"

=B1="Ja"      eintragen

dann unter "Formatieren" - "Schrift" - "Farbe" - grün wählen.

Du brauchst nur eine bedingte Formatierung, denn bei "Nein" ist der Text sowieso schwarz.

Siehe auch Abbildung

Gruß Tron

Keine passende Antwort gefunden?

Fragen Sie die Community