Frage von shooter3009, 62

Auslaufzeit bei Paketberechnung in Excel?

Ich habe eine wie im Bild dargestellte Tabelle erstellt. Die Tabelle zeigt eine Investitionsrechnung.

Die Höhes des täglichen Verdienstes ist von der Anzahl dieser Pakete abhängig.

Die Pakete laufen jedoch ab dem Zeitpunkt des Kaufes nur 150 Tage (Paketlaufzeit). Danach sollen diese wieder von der Anzahl der Pakete abgezogen werden.

Leider reichen meine Excel Fähigkeiten dafür nicht aus. Könnt ihr mir vielleicht weiterhelfen?

Schonmal danke im vorraus!

Hier die Tabelle zum Download: http://filehorst.de/d/bioHIrwj

Expertenantwort
von schmiddi1967, Community-Experte für Excel, 48

Wie soll das bei deiner Tabelle den mit der Paketlaufzeit denn klappen, du hast nirgends ein Kaufdatum hinterlegt.

Warum nimmt immer jeder die Spaltenbezeichnug bei den Bildern raus, habt ihr alle Angst das man euch eine passende Lösung präsentieren kann. Das raten wo was steht macht langsam echt keinen Spaß mehr.

Die beste Möglichkeit ist immer eine Muster Datei irgendwie hochzuladen, dann muß man nichts nachbauen und hat gleich alles vor Augen.

Kommentar von shooter3009 ,

Ich habe die Datei mal hier hochgeladen: http://filehorst.de/d/bioHIrwj

Kommentar von schmiddi1967 ,

Mach mal bitte folgendes, das sollte dein Problem eigentlich lösen.

Einfach und simpel, das Problem ist das man einfach zu weit an was dickes mit irgendeiner Formel denkt und plötzlich geht einem ein Licht auf um so länger man auf deine Tabelle schaut :))

Da deine Pakete sich ja immer nur um das erhöhen was auch nach 150 Tagen wieder abgezogen werden muss gebe mal in Spalte raus in Zelle G159, also bei Tag 151 folgendes ein:

=D9

Das einfach bis an das ende der Tabelle runterziehen:))))))))

Damit werden einfach immer die Pakete die 150 Tage vorher in Spalte Neu eingetragen worden hier aufgelistet. Diese kannst du dann einfach da abziehen wo du das brauchst.

Habe ich das so richtig erkannt ?

Kommentar von schmiddi1967 ,

Und hat es geklappt? Eine Rückmeldung wäre schön :))

Expertenantwort
von Ninombre, Community-Experte für Excel, 47

Wenn jeder Tag eingetragen ist, geht es so (ich nehme an, die erste relevante Zeile ist die 6)

=SUMMENPRODUKT((A$6:A$1000<=A6)*(A$6:A$1000>A6-150)*(B$6:B$1000))

Das liefert je Zeile die Gesamtzahl der Pakete in den max. 150 letzten Tagen.

A6:A1000<=A6 -> nur Tage, die nicht in der Zukunft liegen
A6:A1000>A6-150 -> max. 150 Tage in die Vergangenheit

Da ich nicht genau erkenne, welche Spalte summiert werden soll, bin ich einfach von Spalte B ausgegangen. Das musst Du noch anpassen.

Wenn allerdings freie Tage dazwischen liegen, dann würde ich empfehlen, nicht Tag 1, 2, 3 zu verwenden, sondern ein konkretes Datum. Die Formel funktioniert auch damit.

Falls ich die Frage falsch verstanden habe und Du nicht für jede Zeile die Summe haben willst, ersetzt Du das <=A6 bzw. >A6-150 einfach mit

<=heute() bzw. >heute()-150
Das liefert dann einen Wert für die letzten 150 Tage.

 

Kommentar von shooter3009 ,

Die Sache ist die: wo muss ich diese Befehle denn eintragen? - Sollte ein Paket nach 150 Tagen auslaufen, so soll es in der Spalte ''raus'' mit -1 erscheinen.

Zur verdeutlichung habe ich die Tabelle hier mal hochgeladen: http://filehorst.de/d/bioHIrwj

Kommentar von Ninombre ,

Ich verstehe die Tabelle und die Berechnungen nicht. Es sind keine eindeutigen Kaufzeitpunkte erkennbar: Die Paketzahl ist ja nur gerundet aus Gesamtbetrag / 50. Ist ein Kaufzeitpunkt (ab da laufen ja die 150 Tage) nicht eindeutiger zu ermitteln, außer dass Betrag / 50 ohne Rest aufgeht? So kann man das irgendwie lösen, ist aber alles andere als fehlerfrei.

Auf welchen Zeitpunkt sind die 150 Tage bezogen? Auf den heutigen Tag oder auf historische Termine?

Wenn Du es in jede Zeile eintragen willst, dann muss man den Tag (bzw. besser Datum) dieser Zeile verwenden, um den tatsächlichen Bestand zu ermitteln. Einfach nur -1 zu rechnen reicht ggf. nicht aus, weil der erste Kauf von 10 Paketen an Tag 150 entfällt.

Wenn Du in eine neue Spalte schreibst:
=SUMMENPRODUKT((A$9:A$1000<=A9)*(A$9:A$1000>A9-150)*(D$9:D$1000))

hast Du den tatsächlichen Bestand.

Die Ermittlung der Investition passt dann aber auch nicht richtig. Ich kann jetzt zeitlich allerdings nicht mehr weiter analysieren.

Kommentar von Ninombre ,

Ich blicke allmählich etwas besser durch. Ich komme auf den gleichen Ansatz wie schmiddi - übernimmt in Spalte G ab Zeile 158 oder 159 (je nach dem, ob das Paket an Tag 150 oder nach Tag 150 verfällt) den Wert aus B 150 Zeilen weiter oben. Da reicht wirklich in G158 =B9

Nur musst Du Spalte G entsprechend noch rausrechnen.

Keine passende Antwort gefunden?

Fragen Sie die Community