Frage von 2001HAL9000, 68

Abgleichen in Excel?

Hey alle Zusammen,

ich bastle gerade an einer Exceltabelle, die mir viel Arbeit abnehmen soll. Nur leider herscht hier im System Wildwuchs und dem entsprechend muss die Formel für alles gerüstet sein.

Ich habe eine Liste von Produktnamen und eine Liste von Herstellernummern und ihren Namen. (Spalte D die Nummern, Spalte E die Namen.)

Wenn ich letzt einen Produktnamen (Feld B2) einfüge muss der Algorythmus merausfinden ob einer der Werte aus Spalte D und E da drin vor kommt oder nicht.

Wie das dann mit dem Ergänzen und so weiter ist, das lasst mal meine Sorge sein, ich brauche nur eine passende Suchformel, die bescheid gibt, wenn einer der Werte aus der Tabelle in meinem Titel vorkommt.

Danke Schonmal!

Expertenantwort
von Ninombre, Community-Experte für Excel, 32

=ZÄHLENWENN(D:E;B2)

Wenn größer 0 taucht der Suchbegriff in D oder E (oder beiden) auf

Wenn Du allerdings von Wildwuchs sprichst: Suchst Du nach exakten Übereinstimmungen (Zellinhalt B2 genau gleich wie in den Suchspalten) oder ist damit zu rechnen, dass bei den Namen noch weitere Texte stehen?


Kommentar von 2001HAL9000 ,

Schon besser :) Wir kommen der Sache Näher!
Allerdings taucht wenn dann nur ein Teil des Titels auf
Wenn ich in B "Phillips DVD Player" habe geht es ja nur um Phillips.
Und die Marke kommt halt nur in det Tabelle einzeln vor.

Deshalb muss die Tabelle im Text gesucht werden .-.

Aber ich spöre, wir kommen der Sache Näher :)

Kommentar von 2001HAL9000 ,

Ich habe es jetzt umgedreht

=ZÄHLENWENN(B2;D:E)

Allerdings bleibt das Problem, dass er jetzt nur eine 1 ausgibt, wenn die gesamte Tabelle in B2 vorkommt, können wir das nicht auf einzelne Zellen limitieren?

Kommentar von Ninombre ,

Das klappt aus meiner Sicht mit Hilfsspalten, bspw. F und G

=WENN(D1="";"";WENNFEHLER(FINDEN(D1;$B$2);""))
=WENN(E1="";"";WENNFEHLER(FINDEN(E1;$B$2);""))

Dann

=WENN(SUMME(F:G)>0;"Gefunden";"Nicht gefunden")

Das liefert dann aber nicht nur für Philips Treffer, sondern auch wenn irgendwo DVD Player steht. Wenn das nicht sein darf, musst Du den Suchbegriff genauer eingrenzen. Steht der in B2 immer zu Beginn?

Kommentar von 2001HAL9000 ,

Du musst das halt so sehen, dass in D und E alle Suchbegriffe stehen. Und ich herausfinden will ob einer davon in B2 vorkommt. Wenn das so ist lasse ich B2 unverändert, wenn das nicht so ist holt er sich von wo Anders die Markeund schriebt sie davor.

Allerdings habe ich das mit dem WENN und dem ergänzen schon programmiert. Es geht wirklich nur darum, dass die Suchbegriffe mit B2 abgleicht.

Kommentar von Ninombre ,

Dann sollte die Lösung über Hilfsspalten funktionieren. Die Formeln in F und G entsprechend für alle gefüllten Zeilen kopieren und fertig.

Wenn die Groß-/Kleinschreibung noch ignoriert werden soll, dann statt FINDEN SUCHEN verwenden.

Kommentar von 2001HAL9000 ,

Danke, Deine Lösung mit den Hilfsspalten ist auf Jeden Fall schonmal eine der besten Ideen bisher. Allerdings wird die Tabelle später mit ~20.000 Artickeln gefüllt. (Also Spalte B). Das sind viele Hilfsspalten, die sich nicht wirklich automatisieren lassen...

Um Ehrlich zu sein geschehen die Berechnungen jeweils im entsprechenden B Feld, die eigentlichen Titel liegen im B-Fald auf einer Anderen Tabelle, aber das macht die Frage zu aufgeblasen, das kann ich nachher selber ergänzen.

Antwort
von FragaAntworta, 51

=SVERWEIS("Can1.o";Tabelle2!H:J;3;FALSCH)

Kommentar von 2001HAL9000 ,

Das klingt abenteuerlich aber gut, ich probiere es gleich mal aus und versuche es dann zu verstehen ^^
Danke schonmal!

Kommentar von 2001HAL9000 ,

Hey Dude, wo hast Du denn (Tabelle2!H:J;3) her?

Kommentar von FragaAntworta ,

Aus einer meiner Tabellen, aber vielleicht hilft Dir das weiter, denn ich denke das Du mit SVERWEIS am besten dran bist: http://www.traens.com/tipps/microsoft/sverweis-funktion.html

Kommentar von Ninombre ,

das funktioniert so eher nicht, weil in Spalte H gesucht und das Ergebnis aus Spalte J ausgegeben wird.

Kommentar von FragaAntworta ,

Oho, natürlich funkioniert das, es muss nur angepasst werden, das wollte der FS selber machen, hat ja extra darauf hingewiesen. Und mit ein bisschen bedingter Formatierung kann er das Ergebnis dann auch farbig herausheben. Das Du es nicht erkennst und mit einer Zählewenn Funktion versehen willst, zeigt doch eher, dass Du gar nicht weißt was eine Suchfunktion oder eben auch SVERWEIS ist.

Kommentar von 2001HAL9000 ,

Bei manchen Produkten steht halt ein Markenname im Titel, bei Anderen nicht.

Mein Ziel ist halt, dass die Tabelle nur den Markennamen vor einem Produkt (in B2) ergänzt, wenn da nicht schon einer steht. In E und D Stehen die Markennamen, in B die Titel (Um es zu vereinfachen bleiben wir mal bei B2)

Kommentar von FragaAntworta ,

2001Hal9000, genau dafür ist diese Funktion da, sie zeigt Dir an wo es übereinstimmt, und mit bedingter Formatierung kannst Du es auch farblich anzeigen lassen. Also gehe dem Link nach und versuche es mit dieser Formel, ich bin sicher das es damit geht. Wenn Du allerdings jetzt auch noch eine Ergänzung mit einbauen willst, also den Namen erweitern, dann wirst Du mit "verketten" weiterkommen.

https://support.office.com/de-de/article/VERKETTEN-Funktion-8F8AE884-2CA8-4F7A-B...

Wenn ich Dich richtig verstanden habe, willst Du doch erstmal wissen, wo was vorkommt, wenn Du einen Begriff eingiebst. Dass lässt sich mit SVERWEIS Prüfen.

Kommentar von 2001HAL9000 ,

Zum Verketten kann man auch &"Bla"& Verwenden, aber danke DIr

Kommentar von 2001HAL9000 ,

Hey FragaAntworta, ich glaube, Du hast mein Problem nicht 100 pro verstanden.

Wenn ich einen Produktnamen eingebe steht mal der Markenname mit drin und mal nicht. Ich droppe es in B2.
In D und E stehen die ganzen Markennamen.
Jetzt brauche ich nur eine Formel, die mir zurückgibt ob da ein Markenname im Titel steht Ja / Nein.

Wenn ja, dann bleibt der Titel unverändert, wenn nein packe ich die Marke über eine andere Formel, die ich schon fertig habe dazu.

Kommentar von 2001HAL9000 ,

Gibt es nicht die Möglichkeit

=SUCHEN(D:E;B2)

so zu ergänzen, dass er schon ausschlägt, wenn nur eine der Zelleninhalte im Text von B2 vorkommt?

Kommentar von 2001HAL9000 ,

Gibt es nicht die Möglichkeit

=SUCHEN(D:E;B2)

so zu ergänzen, dass er schon ausschlägt, wenn nur eine der Zelleninhalte im Text von B2 vorkommt?

Antwort
von 2001HAL9000, 37

Hat noch jemand einen Vorschlag?

Antwort
von 2001HAL9000, 14

Gibt es nicht die Möglichkeit

=SUCHEN(D:E;B2)

so zu ergänzen, dass er schon ausschlägt, wenn nur eine der Zelleninhalte im Text von B2 vorkommt?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten