Frage von FTiller, 80

Ich möchte in Excel die Summe aus (A1:A5) bilden. Wenn jedoch in z.B. B3 ein Wert vorhanden ist, dann soll die Summe aus (A1+A2+B3+A4+A5) gebildet werden! ?

Danke für jede Idee und Hilfe! ;)

Antwort
von Funfroc, 43

Hallo,

ich schätze mal du willst die Summe aus A haben, sofern in B nichts steht.
Wenn in B etwas steht soll A durch B ersetz werden, aber nur in der Zeile... kompliziert zu erklären, einfach Lösung.

=SUMMEWENN(B1:B5;"";A1:A5)+SUMMEWENN(B1:B5;"<>";B1:B5)

Wenn also B1, B3 und B5 mit Wert ist, wird die Summe von B1, A2, B3, A4 und B5 ermittelt.

LG, Chris

Kommentar von FTiller ,

Genial, genau das hab ich gesucht! Vielen Dank!

Antwort
von Fardon, 37

Wenn ich das richtig verstehe soll wenn in B3 was steht A3 nicht mehr summiert werden...

Ich würde in diesem Fall die Wenn-Formel an die Summe dranhängen.

Für B3 würde es folgendermaßen aussehen: =SUMME(A1:A5)+WENN(B3<>0;-A3+B3;0)

Ich sage ihm nun, wenn in Zelle B3 ein Wert ungleich 0 vorhanden ist, soll er A3 von der Summe abziehen und B3 hinzurechnen.

Die Formel kann auch noch beliebig mit + erweitert werden z.B. wenn es für Zeile 1 auch gelten soll: =SUMME(A1:A5)+WENN(B3<>0;-A3+B3;0)+WENN(B1<>0;-A1+B2;0)

Antwort
von Jasteni, 41

Also du könntest einfach =SUMME(A1:B5) nehmen.

Dann werden alle Werte von A1 bis A5 und B1 bis B5 zusammen gezählt. Und wenn kein Wert drin steht wird er als 0 gezähltt.

Kommentar von FTiller ,

Hi, danke für Deine Antwort. Leider ist das nicht genau das, was ich
erreichen möchte. Wenn in einer Zelle in Spalte B ein Wert vorhanden ist, soll dieser anstelle von dem Wert in Spalte A in die Summe einfließen.

Ich hoffe, es ist ansatzweise verständlich, was ich meine.

Kommentar von Jasteni ,

Ja ich verstehe was du meinst. Also wenn es nicht zu viele Zellen sind kannst du es mit der verschachtelten Wenn funktion machen. Ansonsten würde ich eine Lösung mittels VBA anstreben.

Kommentar von Funfroc ,

schätze mal, er meint, wenn in B3 etwas steht soll B3 statt A3 in die Summe genommen werden. deines nimmt ja sowohl B3, als auch A3 auf.

Antwort
von Tron1701, 11

Hallo,

ich würde eine 3. Spalte verwenden.

In C1 folgende Formel:

=WENN(B1<>"";B1;A1) diese Formel nach unten kopieren.

Die SUMME aus der Spalte C bilden, dann bekommst Du die korrekte Summe, denn sollte in B3 ein Wert stehen wird A3 in der Berechnung nicht berücksichtigt.

Gruß Tron

Antwort
von Jackie251, 38

sorry hatte die ausrichtung der Tabelle andersrum verstanden - hier die korrektur

dann geht das so:

=SUMME(B1:B5)+SUMMEWENN(B1:B5;"";A1:A5)


Antwort
von Ortogonn, 12

Ohne WENN() und aber ;)

=SUMME(A1:A5)+(B3-A3)*NICHT(NICHT(B3))

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten